Bars At Top of Videos When Using Nyx

  1. When I encode a video using Nyx through NVIDIA Main 10, there are light bars at the top of the video in the form of a gradient. These are most visible on deep blues. They’re not in the source material.

  2. I’m using a 3060 GPU, and a Intel 10900k.

  3. Your log files (Help > Logging > Get Logs for Support)

  4. They’re barely noticeable in a screenshot. The video needs to be in motion.

I also noticed that the bottom section of the video contains light grain which leaves discoloration that’s the same size as the section of bars at the top of the screen. Each of the videos which exhibit this issue, have widescreen bars at the top and bottom, so maybe the denoiser doesn’t know how to process them. I haven’t tested it on a video without bars.

Can you share the exported video with the issue so that we can take a look?

You can securely submit your file(s) to our Dropbox using the link below. Please be sure to send me a note to let me know you sent something and include the file name.

Submit File to Dropbox

File sent. You can see the discoloration at the top and bottom left of the screen. This is where the bars at the top also appear. The bottom has fine noise instead of horizontal bars.

This looks to be some shifting from the Nyx model trying to denoise the dark shadows in the scene you sent and it is generating pixels accordingly. Have you tested it on a video clip without the bars yet?

The issue exists continuously throughout the entire movie. The effect appears on various aspect ratios with the widescreen bars, and it will only appear on the footage itself, so it’s probably related to the black bars. The scene I submitted was from a Handbrake encode in which the black bars were removed after denoising. I will try without the widescreen bars later today. I hope I don’t have to encode the movie multiple times because I’d like to keep the quality as close to the original as possible.

The issue isn’t present when the bars have been removed before processing. Also, if I use the cropping tool in Video AI, would it crop the video before applying the denoise filter? This would save a lot of time if I could do both.

Any crop is applied first and the model will not process what is outside of the crop.

An autocrop similar to the one in Handbrake would be nice. It automatically crops the black bars. Video AI doesn’t seem to detect the bars at the top and bottom or at the sides, and so I have to manually input the dimensions. Being able to fully scan the video for aspect ratio changes would also be good to have. I’ve had Handbrake incorrectly crop videos because they contained a mix of 16:9 and 4:3.

That is a risk with having an auto-crop function is that it can misread the video. In Video AI you should be able to select the ratio setting in the bottom left corner after selecting crop and then manually drag the frame to match instead of just having to put the pixel dimensions in.

I’d prefer to trust software in making an accurate adjustment as I would likely remove too much image or not enough. Handbrake allows you to input the amount of time in which to scan into the video, and from there it will choose the best crop for all aspect ratios. It’ll make cropping a lot easier. Since I’m on the subject of features, I would like to request a minimize to system tray option.

If you want to add that to the Ideas section that would be helpful. That way users can vote to have that feature added.