Autopilot does not disable

When I disable autopilot under settings, it still applies to every photo I load afterwards in V2.4.0.
This is very frustrating as there is an excessive time when I switch photos for it to go through that process, especially when I do not want it in the first place.
This is exacerbated by another bug where if you tweak settings on one photo for noise removal and to adjust lighting with certain settings, and you then apply that to other photos, while the tooltip on those photos reflect the settings applied, when you change focus to any of those photos, the settings get reset to the defaults for noise and lighting.

Steps to reproduce issue:

  1. Go to Edit - Preferences - Autopilot
  2. Chan from enabled to disabled
  3. Import 2 or more photos
  4. Switch focus to a different photo
  5. Everytime Autopilot is run

Topaz Photo AI v4.0.0]on Windows

1 Like

I’m experiencing this too on MacOS. Not only does it not disable, but it appears to be applying Adjust Lighting behind the scenes even on RAW images?

Let’s try updating you to the most recent version release to see if this resolves the issue.

Please make sure you’ve also turned off any firewall, VPN, or proxy that may be on your computer. These are known to block the installation. Also, make sure there are no settings or configurations in your OS system that could interfere.

Try using the appropriate OS system link to update:

If you are still experiencing problems, please reach out to us at the following link:

Topaz Labs | Support Page

1 Like

With 2.4.1, Autorun looks like it’s honoring the Preferences setting.

With a NEF RAW photo:
Autorun disabled, I just get the denoising layer.
Autorun enabled, I get both a denoising and a sharpening layer, both with reasonable settings.

It’s no longer messing about with any other attributes (lighting, tinting, etc) like 2.4.0 was. :+1:

(MacOS Sonoma 14.4, Mac Studio M.2 Max, 32GB)

Thanks! :+1:

2 Likes

I agree, with 2.4.1 I see no overhead from Autopilot now or loss of lighting settings.
Yay!
Glad this was resolved relatively quickly. Thanks Topaz development!

2 Likes