Auto resizing problem

I have a photo taken as a panorama. Its dimensions are 12337x5248. No matter what I try, it insists on croping it to 6720x4480. I have enhanced resolution set to disabled. I do see the size listed in the box below. See screenshot below. I just cannot seem to get it to not adjust the image. I had another Pano 12291x3493 that the program worked just fine with. It made no changes to it. Why is the other one not cooperating?

I just tried some other pano’s and it seems there is a max pixel limit. The 2 other panos are bigger than the one listed above and they to are being resized to 6720x4480. Is there a reason for this size limit? and can it be removed?


Thanks for reaching out. Please send the following information so I can try to reproduce this.

  1. The original image file.
  2. The processed image.

You can securely submit your image(s) to my Dropbox using the link below. Please be sure to send me a note to let me know you sent something.
Dropbox File Request

What camera are these panorama files from? It sounds like we are not opening the files correctly.

Are you using RAW file or non-RAW (like TIF or JPG)?

I uploaded the files as requested.

New Panorama1-original.jpg
New Panorama1-Sharpened in PAI.jpg

  • this file shows the conversion and how it resizes,

The original file is a JPG. Panos cannot be shot as a single raw image. My workflow is as follows:

  • Original images taken with a Canon 5DIV in RAW
  • RAW files converted using DxO with no sharpening
  • Pano stitched together using Panorama Studio Pro 3
  • Image then loaded into Photo AI to sharpen.

Some Pano’s work, but if I had to make a guess, it seems that if the tall side is more than 4480 pixels, it will not open the file properly. I tried with panos less than that and also being about 11,000+ on the long side and it worked just fine.

Thanks for sending the files over. I just tested with the panorama image and I was not getting the file size decrease.

We have an update to Topaz Photo AI releasing later today. Please update and let me know if you are still seeing those issues with the image getting resized.

1 Like

With v 1.3.4 it seems the problem has been resolved. Something changed somewhere and it seemed to have gotten fixed.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.