Apply / Cancel does not work on Mouse Click in all my Topaz products!

Apply button (bottom left) does not work when I click on it in DeNoise, Sharpen or Photo AI (this does not even have File /Apply option), I have to go to File / Apply to get out of it and go back to Corel PaintShop Pro Ultimate 2023! My Mouse works fine with EVERYTHING else on my Windows 11 Pro laptop (even within Topaz products)! So this appears to be a program bug! And this has happened many times in the past few days!

Topaz Photo AI [v1.x.x] on [Windows/Mac]

Did this start recently or has it always worked this way? Please send your system profile so I can check if your computer hardware is up to date.
How to Obtain Your System Profile (Windows)

If there is a previous version that worked please let me know and we can check if the previous version works for you.

Hi Lingyu,

Thanks for responding back! For some reason the problem has gone away on its own. I have an automatic update program for ALL my drivers so it is quite possible that a driver update might have fixed it!

Again, thanks for your response! Have a great weekend!

God Bless!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.