App not useable since the last upgrade (Apple iMac Mini M2 Pro)

The app is not responsible (or at least I have to wait long time something happens). Wenn I am clicking an action it seems to be nothing happens. If I quit the app and press then “cancel” the action I picked is then directly visible…

I am running Topaz AI on an iMac Mini M2 Pro with 16GB.

Please help me to fix this…

Topaz Photo AI [v2.4.0] on Mac

Please follow the instructions below to perform a clean install to better troubleshoot why you had this problem with Topaz Photo AI:

Start by clearing any previous plist files that are on your computer for Topaz Photo AI by following the steps in the link below:

Topaz Photo AI | plist Files Mac

After you have done this, disable any antivirus, firewall, VPN, or proxy software that might be active on your computer. These tools are sometimes known to interfere with the installer’s ability to download the model files.

Please also ensure that the Topaz Photo AI installer has all the proper settings in your system by going to your Mac System Settings > Privacy & Security tab and scrolling down to the security section. You will want to make sure you have 'App Store and identified developers ’ selected. Here is a video example:

Example of Proper System Preferences

Finally, rerun the installer. You can download a new installer from the downloads page directly :

Topaz Labs Download Page

Let me know how that goes for you and I’ll keep an eye out for your reply.

This topic was automatically closed after 60 days. New replies are no longer allowed.