All Topaz applications crashing repeatedly

Hello, all.
I have been using Denoise, Sharpen and Gigapixel for 5 months now. After the recent updates, each of them is crashing just before saving the edited image. I tried getting the image into the app in various ways, as advised by Support, but it is not working.
My MacBook Pro is 1 TB, 16 GB RAM and has handled these applications well in the last few months. Nothing has changed for me to blame the device.
I would like to know if this is a common bug and, more importantly, whether this can be fixed in some way.
Thanks in advance!

Please raise a support request at the main website as this is a user to user forum. You could also post your technical environment here by going to the Help Menu, choose Graphics info., press copy and post the info here

I have raised it to the team. Yet to find a solution.

What is your technical environment, as asked.

Are you able to capture a debugging trace log? This might give the developers an idea where the app is crashing.

Yes, it is turned on. There are many files in the Log folder. But I can’t read any, as my Mac says it doesn’t have any app to read .tzlog files.

You will want to attach the logs to your support ticket. They are intended for the developers to analyze.

I’ve just discover Topaz Lab.
I crreate an account and donwload “JPEG to RAW AI” for a 30 days try.

I’ve the same error.
File cannot be saved.

1/ File format is mandatory or saving crash.

2/ To avoid error at the end of the process, I need to start the software as Administrator (right clic).

My OS : Windows 10. 21H1.

May this help you.

I’m very annoyed with Topaz. I upgraded to version 4 of sharpen and it works. I didn’t upgrade Denoise and it doesn’t work anymore. It’s starts to load and then fails. This looks deliberate to me. If you don’t upgrade the software won’t work.

It is not deliberate.

What is your OS? Is your GPU driver up to date and have you tried reinstalling, download your version from the product release section on this forum.

Gigapixel AI

Defiantly something has broken in this upgrade {5.6.1} I was asked to install yesterday the app works fine until you try to save it.

Model Name: iMac Pro
Model Identifier: iMacPro1,1
Processor Name: 10-Core Intel Xeon W
Processor Speed: 3 GHz
Number of Processors: 1
Total Number of Cores: 10
L2 Cache (per Core): 1 MB
L3 Cache: 13.8 MB
Hyper-Threading Technology: Enabled
Memory: 64 GB
System Firmware Version: 1554. (iBridge: 18.16.14759.0.1,0)
Serial Number (system): C02XK0CTHX8F

BTW the current version is 3.2.2 not 4.