All attempts to install Studio 2.2.0 failed

Topaz Studio 2.2.0 can not be installed and Topaz Customer Service refers with a link to the online installer that does not do what it is supposed to do.
My OS is Win 10 Pro v1909 - 32 GB RAM - Nvidia Geforce GTX 1050 Ti
I have been using Topaz plugins for years and have never had such installation problems.
The Topaz Studio 2.2.0 installer does not work in my Tower PC.

All subsequent attempts to install Studio 2.2.0 failed:
Out of Topaz Studio 2 Beta
TopazStudio2-Online-Installer.exe as Admin
Deinstallation Topaz Studio 2 Beta
TopazStudio2-Online-Installer.exe as Admin

The installer produces in User\AppData\Local\Temp
a bitrock_installer.log
12 tmp files
subdirectory .bitrock & curl

The essential statement of the log file is:
Executing C:\Users\Bernd\AppData\Local\Temp/curl/bin/curl -H “Content-Type: application/json” -d “{"event":"Install Canceled","anonymousId":"a163c89b19ca81ed23bf33bfc427de88","context":{"device":{"id":"a163c89b19ca81ed23bf33bfc427de88"},"app":{"version":"2.2.0"},"os":{"name":"Windows","version":"10.0"}},"properties":{"version":"2.2.0","app":"Topaz Studio 2"}}” https://et.topazlabs.com/v1
Script exit code: 0
Script output: 404 page not found

In Windows Powershell I checked the Script Execution Policy and changed CurrentUser Restricted to CurrentUser Unrestricted.
The parameter Unrestricted will run all scripts, a warning will be issued for unsigned and downloaded scripts from the Internet.
But unfortunately that did not help.

In the above line “Executing C:…” it says “Install Canceled”. I do not understand why? Because of anonymous ID? Or because of a163c89b19ca81ed23bf33bfc427de88 after which I searched in my PC and Registry without result?

For every suggestion to solve this problem I would be very grateful.

This is a new installer. It seems you have an issue with the Installer. What AntiVirus do you run? And are you running in Administrator mode?

Norton Internet Security. Install attempts with deactivated Firewall and deactivated Auto-Protect in Admin mode.

Here is a pic from the not working Studio 2.2.0 Online Installer

It seems that there may be an issue with your screen resolution because I only get these:

image

Try resetting your screen to 100% under display and see if that makes a difference, if not raise a support request at the Topaz Labs main website.

Just a thought - do you by chance have Controlled Folder access turned on?

Settings → Update & Security → Windows Security ->Virus & threat protection → Ransomware protection ->Manage Ransomware Protection ->Controlled folder access. Make sure it is turned off before commencing installation.

Last night I got an email from Topaz Customer Support. Telling me there is a new TopazStudio2-Online-Installer.exe available. Now with the new installer I could set up Studio 2.2.0. Unfortunately I have an issue with the size of the menu which is so tiny that it is unreadable. Apart from that the workspace is ok. I use a 4K monitor with 3840 x 2160 resolution. My Windows display scaling is set to 250% - above that up to the maximum of 350% I get into trouble with other apps. After all no scale problems with the 6 other Topaz AI Apps.

I also have a high res monitor and get the exact same view of the setup wizard with the lighthouse pic. The old Nik software had an issue with high res screens where the fonts were so small they were not readable. Wonder if this is a similar issue. Latest technology shouldn’t at this point…but.

Yes, the old NIK behaved the same petty stingy way on my screen too. Topaz Black & White 2 also. Two years ago I addressed the issue to Topaz Customer Support and that several times. I was told the issue will be solved with the next update which never came.

Thanks for your help. Since I have Norton Internet Security as protection, Windows Security is turned off. All my later install attempts were with the Firewall turned off and Auto-Protect disabled.

My problem is solved now. Today I set up Studio 2 with a brand new installer.

I just tried to install Studio 2.2 update several times and am having the same exact issues as OP, mail-bb. I get the same exact screen with the lighthouse on the left, and it just dies there every time. I’ve tried updating through Studio 2 AND downloading the installer directly from your website, using both links. Nothing works!
I’m on HP Omen laptop, Windows 10, 64 bit, i7-770 @2.80, GEForce GTX 1050-ti, 16 GB RAM. My display is set to the recommended settings of 250% scaling, 3840x2160 resolution. I have Bitdefender antivirus, no ransomware protection, so that isn’t the issue.

I have never had any issues installing or updating any of your products - and I have them all. And never had to adjust anything in my windows settings in order to install anything.

It seems to me, there’s a problem with your installer. And don’t tell me to open a ticket, I have never gotten a response to them in the past. I guess I’ll have to wait on updating until Topaz sorts this out, just wanted to let you know others are having the same problem.

1 Like

Today I got from a Topaz Support Specialist the message: " So, we actually released a patched fix for this issue. I encourage you to shut down the program then once more download the 2.2.0 version from our Topaz Labs Downloads Page [Download] and re-install."
I did what was recommended and re-installed. And voilà the menu is not petty stingy tiny anymore.

2 Likes

I finally got Topaz Studio 2 installed and working. They have an issue with high res monitors that they should fix. I had to set my screen setting from the recommended 250% to 125% in order to view the entire setup screen. Once I did this, I started the install procedure directly from the Topazlabs website downloads section. Once this was completed, I reset my screen to the 250%. Of course, make sure your other applications (LR or PS) are closed during the install process.

Thanks, mail-bb and russjc001. I redownloaded the Studio2 setup file today (11/15) and then I set my screen resolution to 125% - it finally worked.

But crazy to have to install a program at such a small size on your screen - I almost had to pull out my magnifying glass in order to find the file and click on the appropriate commands to install it. See my screen.