AI Gigapixel Desaturation

I’m trying out AI Gigapixel and finding that it is desaturating images… anyone else finding this?

You should specify the image type that you are processing, I.e. RAW, JPEG etc., and it’s ICC Profile and what the resulting image is.

No, not at all. I am converting sRGB to sRGB. Are you inputting Adobe color profile embedded image and outputting sRGB (or the opposite)?

Yes. I am seeing that as well. The blues in my original raw image are coming out desaturated and I have to load the image back into an editor to fix the issue.

The resizing is great, but the images are losing color, at least in my use and for my images, and I have tried this using both sRGB and AdobeRGB. No difference in the output for either setting. All desaturated.

I’m the same as MikeFromMesa… doesn’t matter what color profile I’m using or whether I let it do it itself… I have to take it back into and editor to resaturate it.

Hi guys, the reason I am asking for all relevant information is I am net seeing what you guys are seeing. Try to do the following:

  • Specify the original documents ICC profile
  • Upload a screen shot of the parameters you are using
  • Then a screen comparison of the Original at 100% and the resulting at a relevant zoom, i.e. if you do a 200% upsize the result can be shown at 50% as you see here with the original on top, result on the bottom.

So, here this upsize is done on Windows 10 using a NVIDIA GTX 1050 GPU (4GB) and driver version 398.82 where the input was sRGB/JPEG and output 200% upsize with no conversion … Original TOP, Result BOTTOM:

Here are some screen shots of what you are asking for.

  1. Settings. Keep in mind that I have tried multiple settings, including matching the output to the input, and they all give me the same results.

  1. Screen shot of input. This is a raw file if that is important.

  1. Output from Gigapixel. This was the 150% output but I got the same from the 200% and the 400%.

The output is very good as far as its sharpness is concerned, but it clearly needs to be edited to restore the color.

Some other comments:

a) I am having serious issues with getting the app to run properly. In one case I cancelled a run using the Cancel button and then removing the item with the Trash Can icon. After that reloading the image and trying to run again does not work. That is, nothing happens when I press the Start button. Processing just does not start. I have a screen video of this issue.

b) Trying to exit after cancelling caused the app to hang and I had to force shut it down, and I have the crash dump for that.

c) Creating multiple up-res photos does odd things to the naming. That is, if I create one image at 200% and use the file suffix of _200 to identity the image, that works properly. If I then make another image at, say 150% and use the file suffix of _150 to identify the image I do not get filename_150, instead I get filename_200_150 so the app is keeping the file suffix from the previous effort instead of resting it back to the original name.

There are other things, including some other crashes, but this seems like enough for now.

This is all on Macs, both a Mac Mini and a MacBook Pro.

1 Like

Yes this I believe is a issue with RAW conversion as this has been reported many times with both the Studio and GigaPixel and seems to have not been corrected yet. All RAW converters have subtle differences but not like this.

These are all operational issues and should be raised directly as a Technical Support request with repeatable steps. I will tage Ashley here to look for the Support Request … @ATharp sorry but over to you :slight_smile:

1 Like

Mike has described it perfectly and I have the same issues, including the renaming issue. I have tried various settings as Mike has, and all give the same desaturated result.

I have been doing some additional testing and may have found at least part of the issue.

This morning, out of curiosity, I decided to run Gigaplex on a tiff instead of a raw file and ran two tests. First I processed the raw through PhotoLab to a tiff, loaded that tiff into Gigaplex and ran it at 150%. I then ran a second test, starting with PhotoLab but sending the image to Topaz Studio and through AI Clear, saved that as a tiff and ran it through Gigaplex. Both of those images came back with about the same color as the original tiff, so it is only the raw images that are coming back desaturated for me.

I also ran into another issue with Gigaplex producing a tiff from the tiff even though I had specified that the output should be a jpg, but I assume that should be addressed to support.

1 Like

That is the same for all of us.

Yes that should go straight to support.

> Yes that should go straight to support.

I have submitted 4 issues to support, but those did not include this desaturation issue as it seems to be being addressed here. If that is not right I can also submit it as a bug report as well.

The RAW file conversion issues have been reported many times and the developers are aware, I’m sure.

And that is why it was not on my bug list.

1 Like

Sorry to take a small sidestep here. I’ve used some Topaz software for quite a while but have never engaged in these forums before.

I have two questions. Firstly I thought this was a forum run by Topaz, is it or isn’t it, some of the comments above imply it maybe isn’t but they might occasionally pick something up from the forum.

Secondly you are saying that there are issues/bugs that have been reported numerous times to Topaz but they do nothing about it?

With the issues highlighted in this thread and the comments about bugs not being dealt with I’m certainly not going to be buying Gigapixel after the 30 day trial if this is the state of affairs.

This is a Topaz Forum and they do visit here regularly …

No, what is said is that it has been reported many times, which implies that many people who use GigaPixel with RAW images have noticed and reported, and the developers are working on the issue.

What are the issues that concern you and there are NO comments about bugs not being dealt with? I.E. those that you cannot work around as you would with any other software.

Thanks for the heads up. :thumbsup:

Aidon is correct. Our Raw conversion is having problems with color desaturation.

The developer is currently working on this issue and it is one of our highest priorities.