AI Gigapixel - Changing Colours

(William Boggs) #1

The attached photo has the original JPG file on the left and the enlarged AI Gigapixel JPG on the right. The colours are very different. I have just upgraded to the latest version of AIG. Any suggestions?

(Don) #2

Please post a screenshot of the parameters you used for the processing, just a screenshot of the panel before you processed the input image.

(William Boggs) #3

Here is the screenshot

(Don) #4

OK, please use the same parameters but in the File Format section change “Convert Format For” to “All Files”, change the “Keep Color Profile” to No and see what appears in the “Convert Profile To” field.

If anything except “sRGB” appears there in the “Convert Profile To” field change that to “sRGB”, change “Convert Format For” back to “Only RAW Files” and “Keep Color Profile” back to “Yes”.

That should then work as it looks as though your input file is sRGB.

This is just a workaround as it is a problem that has been reported already. The parameters should look like this for the File Format section after following the steps above to change the profile field to sRGB:

(William Boggs) #5

I am trying this at the moment, though the format of the original JPG file was Adobe RGB.

And …… it worked! The colours are correct.

Interestingly the first attempt (wrong colours) resulted in a 20.6 MB file, while the 2nd attempt (correct colours) resulted in a 9.9 MB file.

Thanks for your help, Don (or Joe).

My screen shot is below.

Cheers

Rex

1 Like
(Sheila Caim) #6

I have the same problem but your workaround fixed it.

Many thanks,
Sheila

1 Like
(andymagee-52287) #7

Thanks for the quick update to fix this!

1 Like
(Randy) #8

I wasnt having issues with color until this latest update.

Now I am having issues. I tried to follow the steps listed here, but once I change the convert for to all files and change it back, I can not reselect color profile to yes, its stuck on no (sRGB)

(Artisan-West) #9

I’m using ver 3.0.5 and some photos change color to a green cast with lower saturation. I tried changing the setting to convert format for only RAW files (my picture is a jpg) and the Keep Color Profile goes to no and grays out so it can’t be changed. I tried it with a photo from a different camera and the color was not changed.

Finally, I opened the first image in Affinity Photo and under Document > assign ICC Profile, I assigned sRGB IECxxxxxxx and then resized again in Gigapixel. This time the color was not changed. I would suggest that if there is no profile in the picture then Gigapixel auto assign sRGB to it before resizing.

Orig photo taken with iPhone:

Photo after Gigapixel (reduced size for posting):

Gigapixel panel:

(Don) #10

For the time being make sure you choose “Convert All” and then make sure the Convert Profile To is set to the correct output profile even if Keep Color Profile is set to Yes or No.

(Don) #11

If that is what you want on the output then make sure All Files is selected for Convert Format For. Click No on the Keep Color Profile to be able to change it.

1 Like
(Artisan-West) #12

Ok, I got it now. Convert format for “all files to JPG”, Keep Color Profile = No and Convert Profile to RGB
It’s like a combination lock. reading all the above had me confused, thanks Don that worked for me since I save as a Jpg.

2 Likes