AI Gigapixel 1.1 Speed Test

(ydobemos) #21

So in the meantime I reset Windows 10 to a fresh install (thankfully nowadays that is super easy to do) and now with the latest graphics card drivers (and with the default Windows ones) it took 14 minutes, so that's a 4 minute gain, but still a little slow compared to you guys.

Seems like despite this being a GPU intensive process in theory the CPU plays a large part as well, since my system uses a mid-range AMD Athlon X4 processor that's not quite up to i7 standards (picking the CPU it was ready to process for close to an hour).

(Terry) #22

I ran artisan-west's 01714.jpg on my desktop computer 16Gb, i5 CPU, Win 10 latest.
GPU is the RX580
I ran on v1.1.1.2, same settings noted in post above on this thread.
Time to Blue Bar 4min 49 seconds and 5min 15sec to the Check Mark.

I have also run several images off fB (.38MB to .42MB) to 10 inch width, 16 bit, moderate, TIFF and they run in 30 seconds or less. Make great prints 8x10 inches.
Thanks for this thread. Great program.

(andymagee-52287) #23

I ran the standard test image again after installing version 2.0.0 and it took 93 seconds with the GTX 980, and 1035 seconds with the i7-7700K. That's 4x faster with the GPU and 8% slower on the CPU.

In both cases the program seems to hang up on the file saving dialog now (it looks like it never finishes), but the file is saved all the same. Perhaps this is an artifact of the new anytime process cancelation code, and will get fixed in the next update.

(andymagee-52287) #24

Doing this standard 16 MB image again at 4X with Version 4.0.0 using the best AI model, max RAM, and Noise Suppression at Low and Remove Blur at High took 156 seconds. (Turning Noise and Blur off only saved half a second.)

That compares to 377 seconds in version 1.1, and 93 seconds in version 2.

Using the not best AI model in version 4 it dropped back to 74 seconds, so that method is even faster than version 2 was.

I wish I had run this test with version 3 to compare that as well, but I seem to remember that not being a significant change from version 2.

p.s. I just ran the test again with 4.0.1 and the times were identical to 4.0.0.

(Don) closed #25