After today's update: Denoise 2.1.2 seems to actually not function

Am I missing something obvious? Launched Denoise 2.0 and it said an update is available. Went ahead and let the update happen and it is Denoise 2.1.2. Restarted the computer to be sure. Launches fine, looks fine, all functions working, but nothing really is different in before/after. Preview and any changes to be applies aren’t showing any difference. Save the ‘changes’ and the file looks exactly the same. It is, in fact the same. Unistalled the software and downloaded the full installer from my account and reinstalled. Still nothing. It’s basically a non functioning program. I wondered if anyone has seen this and knows what the glitch is and how to fix it. 2019 iMac mid level running latest Mac OS version and update.

1 Like

In answer to your question “If anyone has seen this and knows what the glitch is and how to fix it”, I haven’t. It’s working perfectly well for me. I thought there might be a problem when I pulled my first image in to the software because I didn’t see any difference when fiddling with the sliders, but soon figured out there was no noise in that image to begin with. Pulled in another image and it worked as I expected it to. I’m using a Windows machine so perhaps another Mac user will be able to answer this for you.

You’re not alone. I used DeNoise AI 2.0.0 a few days ago and it was great. Today I updated to 2.1.2 and nothing at all happens in either mode, with or within GPU. And now 2.0.0 doesn’t work either. I uninstalled both and installed 2.1.2 again, but that didn’t work either. I tried both a raw file and a .TIFF. Mac OS 10.14.6. I’ll try deleting the plist file next. Edit: That didn’t help. I deleted the .plist file, uninstalled and reinstalled. Still no effect.

I am having trouble with Topaz AI sharpening. It is impossible to save images. The software simply freezes and nothing happens.

1 Like

It may be a Mac issue.

I’m running DeNoise 2.1.2 on a Win 10 PC (with an average, run of the mill system - nothing like high-end gaming or such) and it’s working for me. I’m using mine as a plugin to Ps CC 2020 (latest rel.). See snips of Before & After DeNoise below…

I didn’t crank up the denoising so one spot remains and, as you can see (but the product’s been doing it for a while) it stripped out some saturation in the image’s reds.

One other question for you: Do you have the box that says Auto Update Preview checked on or off? (Pls. don’t be insulted by my asking … sometimes I forget to look myself). If the box is unchecked then you have to hit the “Update” button for the settings you specified to apply. If multiple Mac ppl are writing in about it, then it is most likely something in the code for the Mac installers.



Oddly, I ran into something similar today with Sharpen v2.0.5. (Windows-10)

Sharpen v2.0.0 works as expected. Sharpen v2.0.5 doesn’t process at all. When testing the same image, v2.0.5 doesn’t pop up the processing dialog (v2.0.0 does) and, as mentioned, v2.0.5 does not appear to process at all…unchanged result. It just doesn’t do anything.

I assume it’s not likely to be something funky with my HW…otherwise, v2.0.0 wouldn’t work. (v1.x still works as expected, too)

Perhaps some common code got broken recently…

1 Like

I came over here to see if others were having issues. I have Windows 10 and recently updated the recent one and it seems completely broken. Auto preview doesn’t work. I had to uncheck that and then manually update. When I do the auto settings (which used to be really great), it’s now over-correcting to the point where my image looks almost completely smooth. So I have to do that manually as well.

Sometimes it won’t change the image at all, even noisy ones. I would really like to roll this update back but I’m not sure if I can do that.

Just checked again and having no issues here.

Application & Version: Topaz DeNoise AI Version 2.1.2

Operating System: Windows 10 (10.0)

Graphics Hardware: GeForce RTX 2070 SUPER/PCIe/SSE2 (GPU Processing Setting)

OpenGL Driver: 3.3.0 NVIDIA 442.74

CPU RAM: 16312 MB (AMD Ryzen 7 3700X)

Video RAM: 8192 MB (High Memory Usage Setting)

Preview Limit: 8000 Pixels

If you kept the installer from a previous version you can use that to roll it back. first uninstall the updated version. If not, I have uploaded V 2.1.1 of Denoise to Dropbox.

1 Like

Thx for the Dropbox link! I’ll try it if going back to one of my archived older installers doesn’t work. I download and save them all vs updating in app. I’ve tried to use older installers of Topaz’s in the past and still only got the newest rel. installed. But I’ll give it a go again.

Fotomaker, I tried your original with Denoise V 2.1.1 and got similar results after raising the Denoise level up. The dark spot is not noise, if that is what you are referring to.

Also, Gigapixel will often remove Jpeg artifacts but doesn’t work on all pictures. I tried it on this one and it didn’t work but it might on the whole picture if this is a crop. You can use X1 scaling.

1 Like

Thx for the test & results info/suggestions!

I suspect the one thing that didn’t clean up in the photo was a sensor dust spot (so I wasn’t faulting the program for that…). Sort of looks like the right size for it. It was from an older camera that I no longer use. But I wanted to show whoever had written in originally that at least some of us were seeing differences b/wn the out of cam pic and the apres DeNoise run - it definitely cleaned up what looked like genuine noise at least on this test pic of mine.

I don’t have really small images to test in GAI to see what they do when blown up. But suppose I can try medium size images too to get a sense for how they handle details.

On the no effect with Denoise 2.1.2 on Macs issue: I certainly tried to get an effect with either Auto Update preview turned on or with it Off and manually generating the preview. I couldn’t get an effect whatever settings I used (and no effect was seen in the saved file either).

1 Like

I am using this version on an iMac as a plugin in Photoshop and I’ve noticed sometimes when I adjust the sliders, nothing seems to change on the preview. I found that to be odd behavior. However, most of the time it works as expected and saves correctly.

I have the same issues on a MacBook Pro running latest OS. No apparent difference between preview and original after updating to 2.1.2 :((

I’m running Denoise 2.1.6 on MacOS 10.14.6 and the processing appears to progress but Denoise crashes and does not write an output file in the source folder (as requested).

Anybody else getting DeNoise 2.1.6 crashes consistently?

Everybody is getting MAI (Mask AI 2.1.2) crashes. So now I’m wondering if changes were made to all the installers that are affecting all the products’ performance QA…

Extremely unhappy, hope they fix the problem soon, doesn’t recognize cpu, Extremely slow, worst update ever!