Adjust - One Time Setup for Presets Hangs on Macbook Pro

Trying to evoke Topaz Adjust for the first time in Lightroom CC. The plugin opens, and the dialogue and progress bar says “One time setup for presets,” and it stays this way…forever…or until I click “cancel.” I am new to Mac OS, so I don’t know where to even start troubleshooting. Thanks for any help.

SOLVED: I admit I’m not the sharpest tack in the box, so maybe it took me longer to figure out than needed, but my issue is solved. First I ran the Topaz Permissions Tool, and then I ran the Missing Presets Tool (because the collections and presets panels were empty). A lot of time lost with this…I wonder why the primary installer is unable to check for these conditions and correct them as needed?

I am having the same problem. Updated to High Sierra. Tried to use Impressions and it is taking forever… Where do I find the Topaz Permissions Tool?

This is what you’re looking for:

It says this page is missing.
Please help I’ve had this issue for weeks!