Addressing Windows Sleep/Hibernation

It would be nice if the code was updated to prevent Windows from entering sleep/hibernation during an encode. As things are, I have to set the Windows control panel power settings to “never” to complete an upscale. This isn’t ideal. Thanks.