1.5 version not loading photos on my Mac

I tried drag and drop, I tried Open File but it will only open one photo, the others looks like black tiles, not loading and even the one or two that are properly loaded, I can’t edit at all.
I have quit and reopen the program, I have restarted the computer, I tried import only two photos but it still doesn’t work.

What can I do?

Steps to reproduce issue:

  1. Step 1
  2. Step 2
  3. Step 3

Topaz Photo AI [v1.x.x] on [Windows/Mac]

Please follow the instructions below to fix this issue.
Topaz Photo AI Freezes on Importing Image (Mac)

Let me know if it’s working after doing this.

Hi Lingyu,

I followed the steps, I had to doing twice, first time around did work partially, could load the photos but not edit. It seems fine now.

Thank you for your help.
I would like to uninstall Topaz DeNoise and Topaz Sharpen as I only use the AI now, any tips or just drag them to the bin?



1 Like

You can simply open Finder, go to the Applications folder, and delete any/all versions of Topaz Photo AI from Applications.

Nothing else needed.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.