1.3.5 is damaged and can't be opened in PS

After updating to Photo AI 1.3.5, I now get the following errors “Topaz Photo AI” is damaged and can’t be opened. You should move it to the Trash". I then get the Photoshop error “Cannot Proceed” Error: plug-in has crashed." Have tried reinstalling several times including your download page and get the same error.

In fact, the 1.3.5 update killed your other Plugins as well, Sharpen AI and Denoise AI. I had to reinstall those as well. They work but not as great as they did prior to the 1.3.5 update.

Steps to reproduce issue:

  1. Step 1
  2. Step 2
  3. Step 3

Topaz Photo AI [v1.x.x] on [Windows/Mac]

@jsiatczy-62766 Thanks for reaching out.

Please follow the below instructions to fix it.

  1. Install Topaz Photo AI and run it.
  2. When you see the error appear, ignore it and keep Topaz Photo AI.
  3. Go to your Mac System Settings > Privacy & Security tab and scroll down to the security section. Video here: Loom | Free Screen & Video Recording Software | Loom
  4. You will see a section that says Topaz Photo AI is damaged. Click the option to trust it.
  5. Run Topaz Photo AI and it should work this time.

In the right way, I often uninstall others, and the Windows system has this kind of problem, which can only be solved by copying the 8bf file to the specified path.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.