1.3.10 Subject 'overexposed' after processing with bright outlines

June 22 update 1.3.10 is mostly broken. I am using “Lightroom Classic Plugin Extra”.

Screenshot 2023-06-22 at 7.45.51 PM

Preview looks great:

But the saved result looks horrible:

Topaz Photo AI [v1.3.10] on Mac [M1 Max]

Thanks for reporting this. We hotfixed this issue and released v1.3.11 on Friday after we discovered this bug.

Please update to the latest version and this should no longer happen.

After processing a NEF Raw image in motion blur or lens blur( sharpness,clarity) in TOPAZ AI the subject is totally overexposed when returned back to LR.

Hi Richard, what workflow are you using to launch Topaz Photo AI? Are you using the File > Plug-in Extras menu?

Are you able to upload your original file to this thread here so we can test this?

Sometimes I feel like the issues related Lightroom exceed by far the issues with the Topaz products itself. I will not ask how much development time and money gets lost in the support of those external tools. :eyes:

Hi, yes I use File- Plug in Extras! LR seems to be functioning as expected! This overexposing on returning to LR after using sharpening in topaz happens no matter which NEF Raw file I’ve4 used. They all come back overexposed! I’m not a techie person I just want to use Topaz Ai to get good results! And that’s not happening at the moment!
I have re downloaded LR latest update as I have Topaz Ai as well with no change!
Its only happened since your last update!
All the best …….

@richard.eborall I’ve passed this along to our Topaz Photo AI specialists so they can take a look, but in the meantime, would you mind uploading one of the original files you’re working with so we can test it as well? You can upload the RAW directly to this thread here :slight_smile:

Hi Preston, Since the latest two Topaz Ai updates the problem seems to be solved!So no need for for me to send any files! Thanks and best wishes to all!

Glad to hear it, thanks so much for letting us know!

I just tried this new update out with two raw images and the results are not impressive. Both photos have massive halos and appear overexposed, - I was using the auto pilot by the way. See the pictures below.

I tested this too on an image of a bird against water. The issue is with the masking if you are selecting the bird to be sharpened. Unfortunately, TPAI’s Mask AI feature is not subtle enough to deal with the feathers, whilst the non-AI sharpening does not have edge aware. This makes it nigh impossible to modify the mask. Topaz Sharpen AI would probably be able to do a much better job at refining the mask.

Hi @elancisltd this looks to be a bug in 1.3.10 that we’ve since released an update for with version 1.3.11 – please update to this version and let us know if you’re still experiencing this behavior!

Thanks Werner.
Looks like 1.3.11 upgrade did the trick - problem appears to be solved.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.