1-13-1 works for +/- 45 minutes then crashes!

I am using the latest iteration of CC2019 (20.0.1 release) and Studio is working fine as a plugin. But after 45 minutes or so it crashes, and does not re-open. (I must reboot the PC, Studio then restarts).


Hi Jack,

What if you exit PS … will Studio restart then? Have you tried to restart the standalone version and seeing if that helps?

The other thing that may help is making sure PS has no more than 60% of available RAM allocated and that it is using the same R9 M200X GPU.

1 Like

I have mapped CC2019 and Topaz Studio to the high performance graphics in the Radeon. Memory allocated to CC2019 is as you suggested 60%. It has occurred to me that it might be a scratch disc difficulty I will keep you posted @AiDon

1 Like

It’s still crashing - works phenomenally well for an hour or so - then just closes down!!!

When it closes down do you get a message or is there an entry in the system event log. You can check just by typing event in the search box and start the event viewer. If you then open the Windows Log tree and select Application there should be an Error around the same time attributable to Topaz Studio … there may also be a previous error, probably immediately before, that may mention something like “.NET Runtime version 4.0.30319.0 - There was a failure initializing profiling API attach infrastructure. This process will not allow a profiler to attach. HRESULT: 0x80004005. Process ID (decimal): 9824. Message ID: [0x2509].”

I would copy both the Studio error and any .NET error an submit them to support.

It is strange as I have a Toshiba Satellite P50t-A with almost the same specs as yours except my second GPU is a NVIDIA GeForce GTX 745M.

Your CPU is a i7-4720HQ and mine a i7-4700MQ which is 20GHz slower than yours and the 4600 drivers are different versions (yours later) but that shouldn’t make a difference if it is the MS/Toshiba driver.

Obviously though, I don’t use PS anymore and instead use Affinity Photo so there shouldn’t be much difference. But I don’t get any errors and I am pretty careful about using products so I always shut down anything I am not using.

I think the next step is to have you raise a support request and have one of the support/developers look at your machine. I am sure @JoeFedric-TL can help you more than I can.

TS Just stops. Closes itself down (while processing picture) and leaves me back at Photoshop! I will check those logs. Thanks @AiDon

46 NetRunTime Errors in the past hour…

Unfortunately there is nothing there except the 1026 event which usually means there is a registration issue and you would need to check the setup verification. Fortunately there are tools available on the msdn network to verify that, just search for “verify .net framework”

But first you can do this:

  • Press the Windows key Windows on your keyboard, type “Windows Features”, and press Enter. The Turn Windows features on or off dialog box appears.
  • Select the .NET Framework 3.5 (includes .NET 2.0 and 3.0) check box, select OK, and reboot your computer if prompted.

The dialog should look like this:

You may then be prompted to reboot.

If that doesn’t work then do the search and download a verification tool from msdn.

1 Like

Thanks. Topaz are asking for a Crash Dump:alarmingly there are no CrashDumps at %localappdata%\CrashDumps\ !!!

I will try this verification.

Thanks @AiDon

That 3.5 box is already active. I will search for the verification tool :slight_smile:

It went thru a Windows Installer re-registration procedure…

I have adjusted my Paging File - Updates to Win 10 seem to adjust its size, meaning I have to manually change. Let’s hope that is what is behind it.

1 Like

I think I have narrowed it down to SuperFetch hogging memory and resources - I have just switched this off - the change to the Paging File did not stop TS from crashing!

Having switched SuperFetch OFF, it still crashes! :frowning:

I am beginning to understand that my system cannot sustain Topaz Studio as a Plugin with CC2019 - its works very well as a standalone!

Superfetch shouldn’t be running if you are using SSDs, using a SSD and Superfetch doesn’t load programs into memory.

The other thing is you should set your Paging file to the same size as your RAM.

I’m not using SSD’s. When using Photoshop, CPU goes to 100% - and after a few seconds at 100% - Studio crashes.

I will reset the Paging File again…oops, when I adjusted the Paging File yesterday, on re-opening today it had reset itself to 6Gb!!! I have upped that to 16Gb minimum, 24Gb max.

1 Like

Have you tried using the HD 4600 for both Photoshop and Studio. One thing I do know is that AMD/Intel combinations are not as stable as NVIDIA/Intel.

If I can stop the CPU maxing-out when the Photoshop/Studio combination is working (mostly on AI presets) then I will have found the key to the crashes. I am working with a 16Gb to 24Gb Paging File now, so I will see what happens! It does seem to be only in the AI area that things are going wrong.

Definitively: Win 10 reset my Paging File without warning. I have now reset it to between 16Gb and 24Gb: all is working as it should!

Why does Win 10 do that?! :frowning:

Once you change to custom size it shouldn’t.

The other thing to do is regularly delete everything in the Temp folder.

Just type in %temp% in the explorer bar and you should get to “C:\Users\user name\AppData\Local\Temp” then select all and delete everything.

1 Like

Today Topaz Studio worked for 10 hours non-stop - then crashed!!!