Site Feedback


Topic Replies Activity
Topaz mobile portrait still not fixed! SOLUTION from me! 1 November 25, 2019
Dates on pinned topics 1 November 23, 2019
Annoying design flaw mobile forum 6 November 11, 2019
Having trouble posting an image - additional info 4 August 24, 2019
General Guidelines for using the forum 4 September 4, 2019
Forum Design is Poor and Frustrating to Use for Me - V2 6 July 29, 2019
Unread Flag Stuck 3 July 28, 2019
Icon says I have a message, but I don't see it 1 July 18, 2019
Posting images 4 June 25, 2019
Are There Any Improvements on The Way? 4 May 17, 2019
Image Paucity 3 May 14, 2019
Why several steps to enter forum from Studio? 12 May 14, 2019
Navigation to Topaz Labs site from Forum 1 May 11, 2019
Forum problems for beginners like me 1 May 10, 2019
Community Update 5/1/2019 4 May 3, 2019
Unread Posts Flag Stuck? 4 May 3, 2019
Private Message Functionality? 29 April 29, 2019
Image previews are cut-off 7 April 27, 2019
The side should be better but it is worst 3 April 27, 2019
Forum Design is Poor and Frustrating to Use for Me 15 April 26, 2019
Am I missing a setting or has it just changed? 6 April 25, 2019
"Be Careful What You Wish For...." 5 April 24, 2019
Dark Theme, need Options 14 April 24, 2019
Clutter 1 April 22, 2019
WARNING: A very Inappropriate Posting was Private Messaged to Me on this Forum 15 April 10, 2019
Login problems 8 March 29, 2019
Spammers issues 8 December 29, 2018
Very indecent posts 11 December 28, 2018
Website Not Secure? 14 December 14, 2018
Forums are unreadable in portrait mode on mobile devices 1 September 10, 2018